Unity plugin V4 [deprecated]

At a glance:  The Unity V4 plugin is deprecated. We recommend migrating to the Unity V6 plugin to fully enable app attribution and reporting for mobile apps developed on the Unity development platform. 

Unity.png

Migrating to Unity plugin V6

A Unity plugin V6 is available, allowing app owners and developers to support iOS 14. The V6 plugin also includes significant API method changes from previous versions. To update your plugin from an earlier (V4) version, requires removing/replacing the old plugin. See the full Unity V6 plugin integration guide for developers.

1. Ikhtisar - Unity V4

SDK Unity V4 Appsflyer menyediakan Android dan proyek Unity iOS dengan instalasi aplikasi mobile dan fungsionalitas perekaman event. Ukur instalasi, sesi, dan in-app event untuk mengevaluasi ROI dan tingkat interaksi pengguna aplikasi.

Aplikasi mobile yang dikembangkan pada platform Unity hanya dapat mengintegrasikan SDK AppsFlyer satu kali untuk mendukung instalasi atribusi dukungan bagi kedua aplikasi Android dan yang dihasilkan iOS.

Panduan ini menjelaskan cara mengintegrasikan SDK AppsFlyer ke dalam kode Unity untuk aplikasi iOS dan Android Anda.

1.1 Tinjauan integrasi SDK

Tab Konten Hasil

[Wajib] Integrasi

Bagaimana untuk menambah dan mengonfigurasi SDK.

Dasbor aplikasi menunjukkan:

  • Instalasi organik baru
  • Instalasi non-organik baru

[Recommended]
Core APIs

Bagaimana untuk menggunakan APIs core SDK ke:

  • Ukur event dalam aplikasi
  • Ukur pendapatan
  • Lakukan deep linking
  • Kumpulkan data konversi

Dasbor aplikasi menunjukkan:

  • In-App Event
  • Pendapatan

Siap untuk:

  • Lakukan deep linking

API tambahan

Bagaimana mengimplementasi dan menggunakan APi pilihan untuk:

  • Pengukuran Uninstall
  • Rujukan (atribusi undangan pengguna)
  • Pemberitahuan push

Siap untuk:

  • Mengukur Uninstall
  • Rujukan
  • Keterlibatan pengguna dengan pemberitahuan push
  • Tangani skenario privasi pengguna dan banyak lagi.

Referensi API

Rujukan API SDK cepat bagi programmer

1.2 Kompatibilitas SDK

SDK AppsFlyer mendukung:

  • Integrasi dengan versi Unity 5 dan setelahnya.
  • Google Play Install Referrer API mengawali plugin Unity v4.16.0.
    • Untuk menggunakan Referrer API yang baru, perbarui plugin ke v4.16.0 atau setelahnya.
Apakah artikel ini membantu?

Artikel dalam bagian ini