Интеграция AppsFlyer SDK — Unity. Информация для разработчиков

 Важно!

On 1 March 2020, AppsFlyer will deprecate old SDK versions. To learn about which versions will be deprecated, how it affects you, and how to update to the latest SDK version, click here.

ios.png

Краткий обзор: Unity SDK версия: 4.20.3 на базе AppsFlyer Android SDK v4.10.2 и iOS SDK v4.10.4

1. Обзор

AppsFlyer Unity SDK предоставляет функционал для регистрирования установок и событий для проектов Unity Android и iOS. Вы можете измерять установки, сессии и внутренние события приложений для того, чтобы оценивать ROI (окупаемость инвестиций) и уровни вовлечения пользователей приложений.

Для разработанных на платформе Unity мобильных приложений достаточно всего один раз интегрировать SDK AppsFlyer, чтобы поддерживать атрибуцию установок приложений на Android и iOS.

Это руководство описывает, как интегрировать SDK AppsFlyer в ваш код на Unity для использования в приложениях для iOS и Android.

1.1 Обзор интеграции SDK

Вкладка Контент Результат

[Обязательно] Интеграция

Как добавить и сконфигурировать SDK.

На панели управления (dashboard) показываются:

  • Новые органические установки
  • Новые неорганические установки

[Рекомендовано]
Основные API

Как использовать основные API SDK, чтобы:

  • Измерять внутренние события приложений
  • Измерять доход
  • Производить диплинкинг
  • Собирать данные о конверсии

На панели управления (dashboard) показываются:

  • Внутренние события приложений
  • Прибыль

 

  • Диплинкинг

Дополнительные API

Как внедрить и использовать дополнительные API в следующих целях:

  • Измерение количества удалений
  • Рефералы (атрибуция приглашений пользователей)
  • Push-уведомления

 

  • Измерение количества удалений приложений
  • Рефералы
  • Вовлечение пользователей с использованием push-уведомлений
  • Обработка сценариев конфиденциальности использования и другое.

Справочник по API

Краткая справка о SDK API для разработчиков

1.2 Совместимость SDK

AppsFlyer SDK поддерживает:

  • Интеграцию с Unity версии 5 и выше.
  • Google Play Install Referrer API, начиная с плагина Unity v4.16.0.
    • Чтобы использовать новый Referrer API, обновите плагин до версии 4.16.0 или выше.
Была ли эта статья полезной?

Комментарии

0 комментариев

Войдите в службу, чтобы оставить комментарий.