Применяемая AppsFlyer политика управления версиями

Краткий обзор. Узнайте о политике управления версиями SDK AppsFlyer и о том, какие версии мы поддерживаем.

 Материалы по теме

Чтобы получить полное представление о политике AppsFlyer по управлению версиями SDK, ознакомьтесь со следующими статьями:

О версиях

За прошедшие годы компания AppsFlyer выпустила множество версий SDK. Каждая версия SDK обращается к определенной версии API. Политика управления версиями определяет, как долго API будет обслуживать те или иные версии SDK.

Зачем нам управление версиями?

Задачи управления версиями:

  • Позволяет знать заранее, когда будет прекращена поддержка API для версий SDK, интегрированных в ваши приложения. Это важно, поскольку внедрение версии не происходит моментально: переход пользователей на более новую версию приложения занимает какое-то время.
  • Повышение стабильности (обратная совместимость в течение 2,5 лет) и устранение непредвиденных ошибок при использовании очень старых версий SDK.
  • Возможность использовать новые функции, требующие обновления SDK.

Жизненные циклы версий SDK

Версия API гарантированно работает 2,5 года. Выпуская основную или дополнительную версию SDK, AppsFlyer определяет дату прекращения поддержки предыдущей дополнительной версии (со всеми ее исправлениями).

В следующей таблице приведен пример жизненного цикла версии SDK 5.0.x. Когда вышла версия 5.1.0, для всех версий 5.0.x была определена дата прекращения поддержки — 2,5 года с момента выхода последнего патча.

Версия SDK Дата выпуска Дата деактивации
5.0.0 12.11.2019 30.06.2022
5.0.1 12.12.2019 30.06.2022
5.0.2 23.12.2019 30.06.2022
5.1.0 01.06.2020  

Что происходит при прекращении поддержки версии SDK?

Когда прекращается поддержка версии SDK, серверы AppsFlyer перестают измерять установки, сессии и внутренние события приложения. События, поступающие на соответствующие конечные точки, отклоняются.

Поскольку внедрение требует времени, мы настоятельно рекомендуем переходить на последнюю версию SDK заранее, не дожидаясь даты прекращения поддержки используемой версии.

Была ли эта статья полезной?